SPRX web request (l...
 
Notifications
Clear all

SPRX web request (libhttp)


Posts: 0
Topic starter
(@xelahot)
New RivalGamer
Joined: 6 years ago

Hi,

I know PS3 is getting hella old but there’s something I always wanted to make work on my SPRX projects so I could show a completed project for a future internship. The part that is missing to complete that is an authentification mechanism.

I’ve got my server/database side coded and running well already and I got good encryption and protection methods on the client side. What i’m trying to do is to code a header file that will be able to send a request to a url and get a response back. That requires some of the SDK’s libraries. I understand the proccess that leads to a transaction and response since I read the documentation but I always got issues when building the project. It compiles well bu at the linking it fails.

To make sure I had no errors related to my mod menu and stuff I created an clean project with no encryption or mod menu at all and that builds a working sprx. From that project, I tried using shared code from NGU about Socket requests, HTTP stuff, ... That never worked as well. So what I did was using a SDK sample project that handles libhttp. But again, linking errors. I beleive I’m doing something wrong when linking additionnal dependencies or including headers to my project because either ways I get errors. Maybe my SDK isnt well installed? But that doesnt make sense since I can build my SPRX when im not trying to use network libraries. That SDK copy I have is installed in C:/usr/..../cell/..... and all the files im trying to link/include are there. Maybe someone could explain me the way to use an external library in my project.

The errors I get happen when I call whatever method that comes from a library:

L0064: Linking aborted
	
	L0303: Error generating PRX (prx-fixup failed)

Or sometimes I get errors about variables types like:

_errno is a TLS variable. PRX does not support that.

That’s related to a network library as well.

I tried using this source code as well, but I get the same kind of errors.

[MEDIA=pastebin]kh0z3ZDq[/MEDIA]

This source code header gave me the same errors too.

https://www.nextgenupdate.com/forums/ps3-mods-cheats/754367-sprx-web-requests-simplified.html

****** is actually nex-tgen-update

[MEDIA=pastebin]x6dTz0bC[/MEDIA]

I hope someone can help me or dig into an old project to help me get that http request to work.

Reply
Name of the Video Game, and any other Tags
Menu